Post Reply

Forums -> UltraMon™ -> auto-moving window
Lionel   2016-07-11 00:39
UltraMon 3.3.0 on Windows 10
My system has 3 monitors, but for my everyday use the 3rd monitor is disabled. Monitors are setup in this order 3-2-1, so the rightmost monitor is my primary monitor. Monitors 1 & 2 are driven by an NVidia GTX 750 Ti card, Montor 3 by the onboard Intel HD Graphics 4600 chip.
I have a Weather Station app that I auto start from a shortcut in the Start Menu\Programs\Startup. This app, like most, opens its window on the primary monitor by default. My preference is to have that window in the top RH corner of the secondary monitor. I have set up the UltraMon-Window tab in the shortcut's properties sheet to "use custom settings" "at position: Left -1152 Top 0"
Those postions were set by manually moving the window to the desired position and using the crosshairs icon to copy position and dimns from the existing window.
This set up works OK on some boot ups, but often results in what is shown in the TaskBar as an overlaid double window. But only one window is visible, closing it closes the app. This window is in the centre of the primary monitor. This doubled window can be moved manually, or with the UltraMon buttons, and shows the information expected. I am not aware of any specific set of circumstances causing this to occur. When UltraMon auto-moves the window (on boot up) to the secondary monitor the TaskBar shows a single window. When UltraMon does not move the window to Monitor 2 I close the app, and manually start it from a shortcut on the Desktop. I often have to do this multiple times before UltraMon will move the window to the secondary monitor. Again, when UltraMon has successfully moved the window, only one shows on the Taskbar.
This behaviour occurs on both Windows 10 Version 1511 Build 10586.420 and the "Insider" builds (currently 14385.0.)
I have tried selecting "use custom settings" on the UltraMon-Display tab, and selecting the position, and monitor 2, but that reverts to the default on closing the properties sheets.
An annoyance :-(
Christian Studer   2016-07-11 12:58
To determine if it's a timing issue, please remove the shortcut from the Startup folder and try what happens if you launch the shortcut manually after starting the system.

If this works fine every time, the solution would be to use a script which launches the shortcut after a specified delay.

Regarding the UltraMon - Display tab: this configures custom display settings, for example monitor 2 disabled when you launch the application. It doesn't set the position of the application window.

Christian Studer -
Lionel   2016-07-12 23:16
Thank you for your prompt reply. I don't think that it was/is a start-up timing issue, as starting the app from the desktop shortcut often resulted in the double window central on the primary monitor. But I have delete the shortcut from the startup folder as you suggested, rebooted, then started the app from the desktop shortcut. 1st time - success. Closed the app, restarted it from the desktop shortcut - double window. Closed and restarted, again a double window. Closed and restarted, success again. These tests on Build 14388, issued today.
It may be that some other process is affecting the startup of this app. I guess all I've done is proved that it is not confined to rebooting. I'm about to try starting it from HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run with the value

"C:\Program Files\UltraMon\UltraMonShortcuts.exe" /l C:\ProgramData\Realtime Soft\UltraMon\ShellShortcuts\vws.exe - Shortcut.umshortcut
Lionel   2016-07-12 23:25
Successful moving of the window for the 1st 2 reboots since setting up this "Run" key

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run with the value "C:\Program Files\UltraMon\UltraMonShortcuts.exe" /l C:\ProgramData\Realtime Soft\UltraMon\ShellShortcuts\vws.exe - Shortcut.umshortcut

There may be a better way of setting up the data in that key, I'm no expert.
I'll try a few more reboots to see if it moves the window consistently.
Lionel   2016-07-12 23:35
Successfully moved the window in all of the 4 reboots/restarts since setting up the "Run" key. But I'm not prepared to claim a fix - yet.
Christian Studer   2016-07-13 13:09
If that doesn't fix the issue let me know, it could also be necessary to wait a bit between launching the app and moving the window, that could be done with a custom script.

Christian Studer -
Lionel   2016-07-13 15:19
9 reboots now, and the window has been re-positioned correctly every time. Longest run of successful restarts ever, but I don't understand why.
Lionel   2016-07-16 00:43
Apparently just the luck of the draw. :-( I've had a couple of double window starts.
Christian Studer   2016-07-16 08:34
Try using the LaunchApp2 script instead of the UltraMon shortcut, this supports waiting between launching the app and moving the app's window.

To configure the script, right-click it and select Edit from the menu, then set the EXE option on line 1 to the path and name of the executable you want to launch.

Next set POS on line 3 to "-1152,0" and SIZE to "", then set GET_WND_DELAY to 10, this way the script will wait 10 seconds between launching and moving the app.

Let me know if you have any questions about setting this up.

Christian Studer -
Lionel   2016-07-26 07:03
Thanks, Christian, and apologies for the delayed response. I have been pre-occupied and didn't check the forum til this evening. I've set up the script and it worked as expected on restarting my system. That's only one time, shutting down for the night now. Thank you.
Lionel   2016-07-27 20:06
The LaunchApp2 script has successfully moved the window every time it has been launched to date. :-) Thanks
Forums -> UltraMon™ -> auto-moving window

Post Reply