Post Reply

Forums -> UltraMon™ -> Low quality Wallpaper
Jademalo   2016-10-25 11:38
I have 4 monitors, and recently found this program when trying to mirror one that was connected to my GPU to one that was connected onboard. That works fine, but I'm having an issue with wallpapers.

Regardless of whether I use a high quality JPG or a PNG, UltraMon gives the background image a huge amount of JPG artifacting, as if it's being really heavily compressed.

Is there any way around this?

Christian Studer   2016-10-25 14:01
Does this happen when you create a wallpaper via UltraMon menu > Wallpaper, or when using UltraMon mirroring?

Christian Studer -
Jademalo   2016-10-25 14:35
I mean specifically when setting the background through wallpaper in Ultramon. The actual desktop background is low quality, regardless of mirroring.

I had this problem once before with Windows itsself. I seem to remember that if I used a high quality PNG, it would recompress it and add a ton of artifacts. If I used a high quality JPG however, it wasn't recompressed and wouldn't artifact.

Ultramon seems to result in the same amount of artifacting regardless of what I use to set the background image.

It's mostly an issue because my background is pixel art, and pixel art looks awful with JPG compression.

Here's an example of what I mean;

You can very clearly see all of the artifacting in the top image, but the bottom is totally fine.

Christian Studer   2016-10-25 15:35
Could you send me the image you're using to Please also let me know which version of Windows you're using.

Christian Studer -
Jademalo   2016-10-25 15:44
I've sent you those as requested.
Thanks again!
Christian Studer   2016-10-26 15:24
Thanks for the image, I've been able to reproduce the issue.

Turns out this is actually a Windows issue, the problem is that by default wallpapers get compressed, which also affects the bitmap wallpaper generated by UltraMon. To prevent this, run regedit.exe, then go to the key HKEY_CURRENT_USER\Control Panel\Desktop and create a new DWORD value named JPEGImportQuality. Setting this value to 100 (decimal) will disable compression.

Also see How to disable wallpaper JPEG quality reduction in Windows 10 for more on this issue.

Christian Studer -
Ted   2016-11-05 16:08
I didn't realize Windows 10 changed the Ultramon BMP to JPG. It would be a nice change to have Ultramon save its wallpaper as 24-bit PNG; I notice Windows doesn't change that to JPG.
99% of my source files are PNG to begin with, so I do have a bias.
Forums -> UltraMon™ -> Low quality Wallpaper

Post Reply