Post Reply

Forums -> UltraMon™ -> Video player applications not showing up as an option to select
Michael   2018-09-25 19:59
Media player classic (MPC) nor Windows 10 Movie & TV both do not show up as a option to select using ultramon's mirror an application window tool in the new 3.4.0. (recently updated to find this issue that I did not have before)

I use to use MPC all the time with ultramon to mirror the video being played to the projector with the previous version, which worked great, now Ultramon does not see the app MPC (it shows the folder it is playing in - which is no help) and therefore can not just mirror the MPC app, I have to use mirror a part of a desktop and although this works it is awkward to use and wondering if this is going to be fixed?

In the meantime, is there a problem if I just go back to the previous version (UltraMon_3.3.0_en_x64), i.e will it be a problem with current Win 10 systems?
If not a problem, what is the best way to go about it... would I try to install over top (so I keep all of my original settings and licencing info) or should I uninstall the newer version all together first, then install the previous version, then having to redo all my settings and licencing?

I prefer to use MPC as it has a nice minimalist no boarder view of video, and doing a mirror of that MPC video is very effective, clean, and easy way to mirror it to the projector quickly and sometimes I work while someone else is watching, and I can work without worrying that another application or window will interrupt the video output. I also notice it takes less cpu resources just sending the MPC video app screen output to the projector also. So I really would like to get this working like it was before.

Christian Studer   2018-09-26 15:16
Which version of MPC are you using? I tested with MPC-HC 1.7.13, works fine for me on Windows 10 version 1803 with UltraMon 3.4.0. The app is listed as an available application and gets mirrored correctly.

Movies & TV also gets listed on my system, but mirroring doesn't work, you just get a black screen.

Going back to 3.3.0 is no problem, you'll need to uninstall 3.4.0, reboot, then install 3.3.0. Most likely your settings for 3.3.0 are still there, to confirm this run regedit.exe, then check if the key HKEY_CURRENT_USER\Software\Realtime Soft\UltraMon\3.3.0 exists.

Christian Studer -
Michael   2018-09-26 18:41
Thanks for your response. I am running MPC-HC vs your MPC-HC 1.7.13. When I went to my version opened up help and asked to check for updates, it said this was the latest stable version. does confirm your version as the latest, installed it anyways and somehow it is still associated to the older version, but the newer 1.7.13 does work, so problem solved.
Now just have to find the old version, where it is installed and wipe it off my system and re-associate video files to the new version.
Thanks a lot!

Michael   2018-10-01 17:52
Just in case someone else is in the same situation as me...

One other quirk currently with the latest media player classic and Ultramon versions, is with the new version, it does not see the video you are playing with media player classic if it is in no boarder mode, so you need to put the menu and boarder on, then it will see it and be able to mirror it.

Once Ultramon see's media player classic and you mirror it, then you can go back to boarder-less mode and it continues to work for nice view to projector output.

Christian Studer   2018-10-02 04:42
I'm seeing that as well when running MPC-HC without borders, happens because UltraMon doesn't recognize the borderless window as an application window.

I'll look into this, not sure though if there's a fix without messing up other things.

One thing you could do is use MirrorMon instead, which will work fine with the borderless window. It would also be possible to automate this with a script, if you're interested in this let me know.

Christian Studer -
Forums -> UltraMon™ -> Video player applications not showing up as an option to select

Post Reply