Post Reply

Forums -> Multiple monitors -> The currently selected graphics display driver can not be used. ...
Bob   2005-05-21 12:18
When I go to Control Panel -> Display -> Settings I get a pop-up with this message ...
"The currently selected graphics display driver can not be used. It was written for a previous version of Windows, and is no longer compatible with this version of Windows.

The system has been started using the default VGA driver.

Please contact your hardware manufacturer to get an upgraded driver, or select one of the Microsoft provided drivers."

My original monitor is on "Plug and Play Monitor on NVIDIA GeForce MX 200". It continues to work fine. I installed a "Plug and Play Monitor on Matrox Millenninum G450 DualHead DVI PCI" for my new monitor. I have the latest drivers for both adapters. I already had the latest BIOS for my card but loaded it anyway. It made no difference.

This is really frustrating. So if anyone can help me I would sure appreciate it.

Thanks, Bob
GR   2005-06-16 00:17

Sorry I don't have a solution, just a little info.

I have the same message. It started yesterday after upgrading a stable 2 video card system with the latest Microsoft security patches and latest AGP video drivers from Microsoft upgrade. In my case the first card is AGP Video for Visiontec Xtasy 9200SE (ATI chip) and the second card is a PCI NVIDIA GeForce4 MX 4000. In my case the error message applies to the NViDIA card in the PCI slot but the NVIDIA card drivers had not even been updated. If I disable the AGP card, then the PCI card works fine,

Since then I have updated drivers on both video cards. Re installing the ATI drivers fixed the problem for 2 or 3 reboots, then the same problem re-appeared.

Just a guess, but from testing I suspect it is a Windows configuration problem - see the microsoft support page at It references a different set of circumstances but still say the problem can have nothing to do with the actually drivers.

If I find a solution I'll let you know.

webtrader   2005-07-17 13:41
Anyone find a fix for this? Please post....
Martin Smallridge   2005-08-16 23:45
Ok, this is purely based on my own peculiar setup but it might help those of you who are ready to join a monastry.. :)

I started with a Matrox G450 and an ATI Radeon 7000 both PCI in Gigabyte AN8XP-9 which has an PCI-Express slot in it...

I'd opted to get a Nvidia 6200TC PCI-E card so I could play sims2.. (yes I know :P) and started by just plonking the PCI-E in with the other 2 cards still installed.

It was not having it...

So I figured it was the ATI, removed the drivers and then the card before rebooting... still not happy with the issue of it acting like a VGA card but not displaying any errors.

Ultimately what I think worked is this:

- Uninstall ALL the various drivers and utilities for ALL the video cards
- reboot
- login and cancel ALL PnP requests to reinstall your video cards
- Run your Matrox installer (obviously grab the latest one)
- Reboot
- If you want to use multi-display enable this now and reboot
- Now allow the PnP to install the Nvidia driver

NB: I didn't install ANY of the enhancement utilities for nvidia at all.

- When it prompts you to say that you have a desktop manager already in use (Matrox's Powerdesk) choose to disable Nvidias own desktop manager.

From there on in I found that I could use the system just fine.

Worth noting that I installed the drivers, had all my problems and then went the route above so you may well have to suffer for a bit with all drivers installed before you can go any further.

Hope it helps though...
Martin Smallridge   2005-08-18 22:12
I stand corrected...

I "thought" I'd figured it out but as it turns out the Nvidia 6200TC is the biggest, most unco-operative piece of **** going.

The Matrox / Nvidia combo worked with clashes but left me with some distinct concerns because it resulted in the Marvell LAN port disappearing and clashes with the PCI-express root ports suffering from insufficient resources.

Add to that the ATI / Nvidia combo resulted in the message shown the first message (after initially co-operating) but more worryingly it also caused no end of problem with my net connection to the point of causing it to fail to reach websites that weren't in dns cache..

To say that it's been a learning experience is putting it mildly... :-/
Lorcian   2008-07-04 05:13
Well, i found a solution!

The hardware used isn't the same configuration, BUT i think the therory is the same.

The aim was to have a tri-monitor setup using my 8600GT and a voodoo 3. I bought an ATI card, but they didn't want to play nice together so I used an old voodoo I fond in the loft.

Anyway, I uninstalled both cards, Installed the older PCI voodoo first, made sure that worked, THEN rebooted and installed the driver for the newer 8600GT PCI-E card. It worked!

I'm not sure if it'll work with the hardware you listed, but perhaps the process is the same.

Good luck!
mitch   2009-11-15 04:50
I finally figured it out, after 2 days of trial and error!
I have a 3 monitor setup at home and at work - after comparing the registry keys of both PCs, I found this solution:
In the Registry Editor, somehow a line got removed in the problem PC. To fix the problem goto
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management and make sure this is in there : SessionImageSize
It was in my home PC, but not at work (the problem PC)
I went to Edit -> New -> DWORD Value and called it SessionImageSize and gave it a DECIMAL value of 32.
After rebooting, the problem was fixed!!

Mark   2010-07-09 23:37
Thanks a heap for that, had the same problem and that fixed it, thanks
DSA   2011-04-21 08:07
Although this is an old post, I just ran across it and the regedit trick solved my problem without messing around with all the drivers! I had XP with a ATI radeon 9600 and added an old Nvidia PNY quadro NVS 280 pci so I could have up to 4 monitors. XP choked when I tried to extend the desktop on the quadro monitors, and I spent hours trying to figure it out, but then I finally found this post and did the regedit entry, rebooted, and everything works great!
WIll   2011-06-10 09:46
Sweet! That regedit trick totally did the trick. I don't know how you tracked that down but my hats off to you, sir!
Dan   2011-07-22 14:19
Thanks a lot!
andy   2011-07-26 09:05
hi all
i have a simular problem after my old card become damaged after i removed it...DOH!,but pre op it was showing signs of deteriation ie line and blocks on screen, so i thought oh well i need a new one and treated myself, the comp showing the video input on old card, now the new card is inserted i am getting the very same message, i cannot go into bios and certainly cannot see wondows screen, i am running windows xp64(don't ask!!!) and my mobo is msi K8t neo2 939.
The new card is gigabyte HD 4650 agp1gb gddr2, i did not remove any drivers as the screen went blank before i had chance, any advice would be great!!! or should i just go for the hammer!!!!?

andy   2011-07-26 09:08
WINDOWS!!!! not wondows grrrrrrrrrrrr!!!

Claris   2011-08-07 06:55
I have the same problem and the regedit didn't fix it. I have a Mobile intel 965 Express Chipset Family... I don't know when the problem happenned, I never installed a new monitor...
Jorge   2011-10-08 12:19
Awesome!!!! The regedit workS!!!!
DOR   2011-10-22 20:28
Wow. I spent hours trying to get this thing to work, but this RegEdit did it. Thanks. REGEDIT WORKS !!!!
Chris Brett   2012-01-17 21:39
Mitch: Well done, that is an excellent solution to an annoying problem. Thank you very much indeed.
Mark   2012-01-28 15:21
Same problem, I upgraded video cards on a 3-monitor set-up, and when installing the second card I got the error message. This fix worked for me! Although I wasn't missing the registry key, it was set to 16 (0x10). I upped it to 32 (0x20), rebooted, and everything worked again. I then backed it down to 24 (0x18) and it still worked, so I'm leaving it there and making a note to myself for future reference.

I also found this link that helps explain why this problem occurs, and why this fix is legit.

For those where this fix doesn't seem to work, I'd say trying upping it a bit more. Perhaps you have very large drivers and need just a little more space to hold 'em.

I'm SO glad I found this forum and this solution. THX!!

redd   2012-02-07 21:49
wow works like a charm..ty
Manikandan   2012-11-26 05:00
I am getting Error msg like The currently selected graphical driver can not be used.
Brazievans   2012-12-05 04:28
The fix published by MITCH solved the problem. Please try the Registry Edit fix for sure.

jack   2013-03-03 15:49
hi,i have the same problem,,didt the regedit thing but it didnt help,,the thing is that when i turn on my toshiba laptop the desktop and everything is blurry,,any help?
Forums -> Multiple monitors -> The currently selected graphics display driver can not be used. ...

Post Reply