Post Reply

Forums -> UltraMon™ SDK -> UltraMonIndDisp.exe remains running
Ben   2008-06-11 17:12
I'm using ultramon with VB6 to control a 2nd monitor. When our VB application is closed UltraMonIndDisp.exe remains running (I can see it in task manager) for around 30 seconds after.
If the application is restarted before UltraMonIndDisp.exe has closed we get some strange behaviour.

The references to ultramon are declared as follows...
Global umWnd As New UltraMonWindow
Global umSys As New UltraMonSystem
Global umInd As New UltraMonIndDisp
Global umUtil As New UltraMonUtility
Global umMon As ULTRAMONLib.IUltraMonMonitor

and these are all set to "Nothing" when the application closes.

Any ideas how I can tidy up references properly, or is this behaviour to be expected?

Ben   2008-06-11 17:15
Follow Up: Sorry I forgot to mention i am using Ultramon version
Christian Studer   2008-06-12 09:48
This seems to be standard behavior for out-of-process COM servers like UltraMonIndDisp, I'm not aware of a way to change this.

What kind of problems do you experience when you restart your application with UltraMonIndDisp still running?

Christian Studer -
Ben   2008-06-15 22:58
The problem we experience when UltraMonIndDisp is still running is that DetachedApps.LaunchAndAdd fails to launch the app on the 2nd monitor. It appears on the main monitor instead.
Christian Studer   2008-06-16 11:18
I have now done some testing, my guess would be that the following happens:

1) your app starts and detaches monitor 2, then launches app2 on the detached monitor

2) your app exits. This causes the detached monitor to get attached again, but app2 continues running on monitor 2

3) your app gets started again, and again detaches monitor 2. UltraMon will then move the still running app2 to monitor 1, as the app is no longer allowed to run on the detached monitor

4) your app starts a second instance of app2, which gets moved to the detached monitor 2

5) the end result is that you now have two instances of app2, one on the detached monitor, one on the primary monitor

Christian Studer -
Forums -> UltraMon™ SDK -> UltraMonIndDisp.exe remains running

Post Reply