Post Reply

Forums -> UltraMon™ -> stuck task bar
Achintya   2002-12-03 17:30

I have another task bar problem!

Not only can I only get 2 of my 3 monitors to display the smart task bar, I have also found that the 2nd task bar (the primary monitor one is ok) does not autohide. The only way to get it to recover this function is to turn off the smart task bar function then put it back on again, and the auto hide works again.

Any ideas?


Please post any replies to the forum and copy to:

many thanks
Christian Studer   2002-12-04 00:11
Hi Achintya,

I guess you are using the 2.0 final release?

Another user had the same problem, occasionally the taskbar would no longer autohide. So far I haven't found out what causes this, unfortunately I haven't been able to reproduce this problem.

Please let me know what operating system you are using, and if there is any pattern to this problem, for example it starts after launching a specific application, etc.

Christian Studer -
Achintya   2002-12-04 00:32

There doesn't seem to be any 'pattern' to this autohide problem.

There is no particular action that is causing it.

I am using an XP windows PC, lots of ram, no problems that I am aware of.


Please post any replies to the forum and copy to:

many thanks
Christian Studer   2002-12-04 05:36
I have uploaded a test version of the taskbar which sends diagnostic information to a debugger:

To see the information, you'll need to have a debug monitor running in the background, for example DBWIN32.

If you experience the problem again, please copy the last 20 lines of debug information from DBWIN32 and post it here.

Christian Studer -
Steve   2005-02-15 18:52
I found this on another forum.

It worked a treat for me too.

Good news :- I've been having this infuriating problem as well for a while, but I
just fixed it by installing "Taskbar Activate" by Pierre-Marie DEVIGNE.

It's free and you can download it from

Once you install it, make sure to go into settings and take off "Delayed Activation
of the Taskbar". My taskbar is working fine now after this.
John H. Harris   2009-02-04 22:20
I just installed the new version on my new Vista 64 bit system, and I'm getting the same auto-hide problem I got on my old XP 32 bit system.

Turning off the smart taskbar seems to fix it, but please tell me you guys are working on a permanent fix.
Christian Studer   2009-02-05 08:44
I'm not aware of any issues with autohide in 3.0.4, what happens if you have autohide enabled?

Christian Studer -
Tilluan   2012-02-06 00:04
Same issue.
Windows 7 Enterprise
64-bit (4GB)

2 monitors
Current desktop: 3840x1200 (0,0 - 3840,1200)

Monitor 1 - HP ZR24w (primary):
Settings: 1920x1200, 32-bit color, 59 Hz refresh rate
Coordinates: 0,0 - 1920,1200. Workspace: 0,0 - 1920,1200
Video card: Intel(R) Q45/Q43 Express Chipset
Device: \\.\DISPLAY1\Monitor0

Monitor 2 - HP ZR24w:
Settings: 1920x1200, 32-bit color, 59 Hz refresh rate
Coordinates: 1920,0 - 3840,1200. Workspace: 1920,0 - 3840,1200
Video card: Intel(R) Q45/Q43 Express Chipset
Device: \\.\DISPLAY2\Monitor0
Tilluan   2012-02-06 00:05
UltraMon 3.1.0
Christian Studer   2012-02-06 08:58
What taskbar settings are you using? You can check this via right-click on the main taskbar, then select Properties from the menu.

I did some quick testing on 64-bit Windows 7 with both taskbars set to use autohide, but noticed no problems.

Christian Studer -
Forums -> UltraMon™ -> stuck task bar

Post Reply