Post Reply

Forums -> UltraMon™ -> Disable Wallpaper If Terminal Services Session
Bill Swart   2002-12-07 22:09
After installing UltraMon on Windows 2000 Server, it sets itself up to launch out of my Startup folder. This is fine for a local login but when I login remotely via a Terminal Services session, it also launches UltraMon and displays my primary monitor wallpaper. The display of the wallpaper across a 28.8K link causes extremely slow session performance.

One solution would be to manually launch UltraMon (only when logging in locally). However, it would be nice to just disable the wallpaper for a remote session. Does anyone have any suggestions on how to accomplish this or some other way to deal with this issue?
Christian Studer   2002-12-08 06:10
I'll fix this in the next release, UltraMon won't refresh the wallpaper when running in a remote session.

BTW, I noticed that this only happens when you are logged in locally as well. When nobody is logged in locally, the remote session has a blank wallpaper.

As a workaround, you can disable automatic wallpaper refreshing: Wallpaper > Options, uncheck 'adjust wallpaper when display configuration changes'.

You can still refresh the wallpaper manually, either by opening the wallpaper manager or by running UltraMonDesktop.exe (in the UltraMon directory) with the /refresh command-line argument.

Christian Studer -
Bill Swart   2002-12-09 10:17
Christian - Thanks for the quick response and the suggested workaround!
Jeroen Cuppen   2002-12-22 08:32
Hmmm I would not be very happy with this change (could live with it though).

I have a high speed internet connections and I like to have a wallpaper. Ultramon currently scales and recreates the wallpaper automatically and hides the secundary one.

There are other options though. I'm using .net server rc2 so it might be a little different, but when using the default terminal client that comes with windows xp, you disable the wallpaper from the client. It then hides the wallpaper completely, even if ultramon tries to update it.

So if you disable it for remote desktop I'd prefer if it was an option you could select.

I have more problems with programs that startup when loging on but most of those programs only make sense on the console session (keyboard drivers, remote control software for my TV-card etc), I'm planning on making a simple program I want to put in startup that executes a list of programs, but only if the session isn't a remote desktop session. Do you know how my program can detect if i'm on a console or a remote session?
Christian Studer   2002-12-22 08:40
XP behavior will remain the same, the fix only applies to Windows 2000 Server.

You can use GetSystemMetrics with SM_REMOTESESSION to check if the app is running in a remote session.

Christian Studer -
Jeroen Cuppen   2002-12-29 05:21
thanks for the info. The startup works good now and now I don't have conflicting stuff anymore :)
Forums -> UltraMon™ -> Disable Wallpaper If Terminal Services Session

Post Reply