Post Reply

Forums -> UltraMon™ -> Google Chrome Issues with Maximize to Desktop and Move Window Buttons
Joey   2017-12-04 20:37
In Google Chrome, when the window is maximized (in a single monitor), if you have enough tabs open to bring them all the way across the screen, the Chrome "New tab" button gets covered up by the Maximize to Desktop UltraMon button (i.e., so when you try to open a new tab, you end up triggering the Maximize to Desktop function instead of getting a new tab open).

When the window is NOT maximized, the buttons are higher up, and thus out of the way of the Chrome "New tab" button.

Lastly, I login to Chrome (to share bookmarks, etc) and when I do there is a menu open that I can click on (which in my case is just my name, "Joey"), but when clicking this button it triggers the Move Window function.

It seems the solution to this would be to move the buttons to the left for Chrome in particular and to keep them higher / out of the way when the Chrome window is maximized.

Is this possible? If so, how would it be done?
Joey   2017-12-04 20:46
Okay, so, good news in the case when the window is NOT maximized.

Using the compatibility options and using 50 pixels in the "Custom button spacing" field helped, they are no longer being covered.

The only problem now is when the window is maximized and there is a large number of tabs. When that occurs, the buttons (now moved over to the left) start to ride on top of not only the "New tab" button but also bleed over top of right-most tab as well.

Any thoughts on how to deal with that?
Christian Studer   2017-12-06 02:33
I'm going to look into that, but not sure yet if there is a good solution.

Firefox is the best browser in this regard, it supports adding spacing between the tabs and window buttons, making room for the UltraMon buttons.

Christian Studer -
jyang   2019-01-14 04:47
One solution might be to modify the "Custom button spacing" option so that you can move a certain number of pixels to the *right*, rather than to the left (or otherwise crowd the buttons into the empty space between the rightmost Chrome tab and the three standard Windows minimize, maximize, close buttons)? Maybe allow a negative number to be entered (if leaving the rest of the option the same, i.e. moving to the left by default)?
Christian Studer   2019-01-14 14:24
Might be an option, or smaller buttons just the size of the icon.

Christian Studer -
cabenjam   2019-01-25 10:31
Can no longer get the window buttons to display in Chrome (v71.0.3578.98, 64-bit) or Firefox (v64.0.2, 64-bit). None of the compatibilty options work. The "force window buttons" can be set for both, when looking at the settings for currently open browser windows, it is unchecked - so seems the setting isn't being applied. Also, attempting to use the "use alternative method to add window buttons" for Chrome causes UltraMon to crash/close.

Worth mentioning in case it may be related: Windows 10 updated to v1809 this morning.

But on that front, the buttons still work fine in MS Office apps and the MS Edge browser.

Christian Studer   2019-01-25 14:33
Upgrading to UltraMon 3.4.1 should fix both issues, this release added support for version 1809 of Windows 10. The window buttons work fine for me with both Chrome and Firefox on Windows 10 version 1809.

Christian Studer -
Jeremy Goodell   2019-02-28 12:13
My PC was just upgraded to Windows 10 the other day. I re-installed Ultramon (v3.4.1), and now I have this issue with maximized Chrome windows with a lot of tabs -- when I try to click the + button to add a new tab, it invokes the Ultramon stretch window button, causing the window to resize to fit across both monitors. There is no way to click the "+" button to get a new tab when Chrome is maximized with more than 6 tabs open.
Jeremy Goodell   2019-02-28 12:15
This is on Microsoft Windows 10 Enterprise, v10.0.17763, and chrome: Version 72.0.3626.119 (Official Build) (64-bit)
Christian Studer   2019-02-28 15:36
There's no real fix for this, but you could disable the UltraMon window buttons for Chrome via UltraMon Options > Compatibility.

I'm going to look into possible solutions for a future release, maybe an option to use smaller window buttons for specific applications.

Christian Studer -
Jeremy Goodell   2019-03-01 07:50
Thanks for the reply. Disabling the buttons isn't really an option since I use them ALL THE TIME in chrome. As a software developer, I am constantly moving my chrome windows back and forth and I always have at least 10 or 12 tabs open. However I did discover that I can just do ctrl-T to open a new tab. So, with a slight behavior modification, this won't really be an issue for me.
Steve Bush   2019-12-23 09:37
I just ran into the same problem. I rarely, if ever, use the "stretch" button and that is the button that is conflicting within Google Chrome when maximized. So, I disabled "Utramon/Buttons and Menu Commands/add Maximize to Desktop button"

That works great for Chrome, but it would be nice to have that as a "Ultramon/Compatibility" setting for individual applications
Forums -> UltraMon™ -> Google Chrome Issues with Maximize to Desktop and Move Window Buttons

Post Reply