Post Reply

Forums -> UltraMon™ -> Mirroring a tablet in kiosk mode
wtnh   2022-05-13 05:59
I am trying out UltraMon to mirror a Surface Go2 running Chrome in kiosk mode to a 40" Samsung monitor. The monitor is set up as an extended display in portrait mode. The connection is USB 2 to HDMI. The Surface is running Windows 10.

This all works fine, but I have two questions:
1) How can I set UltraMon to automatically start in mirror mode on a reboot?

2) Can the frame rate be improved? I have some web pages with embedded video and while it displays smoothly on the Surface, there is some video "judder" on the extended display.


wtnh   2022-05-13 06:00
oops - I meant USB C, not USB 2 :-).

Christian Studer   2022-05-13 14:35
1) go to the folder C:\Users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup, then create a new shortcut there and set location of item to the following:

"%ProgramFiles%\UltraMon\UMMirrorClient.exe" /start lastmode

Please note that the AppData folder is hidden by default, you can show it via the View menu in File Explorer.

2) did you already adjust the screen update rate on the last page of the mirroring settings? By default this is set to 5 frames per second.

Christian Studer -
wtnh   2022-05-15 09:25
Thanks for the suggestion on autostart of mirroring. I think that will take care of the issue.

The frame rate for video is set to the maximum of 30fps, but the video update rate is something less than that - I would guess I am seeing around 10fps, which results in a not smooth video. Perhaps frames are being dropped. The video on the tablet is smooth.

I would guess the GPU in the Surface Go 2 is the limiting factor, but wondering if there is a software fix?

Christian Studer   2022-05-16 16:48
What resolution are you using on the internal and external screen?

Christian Studer -
wtnh   2022-05-17 06:28
The Surface Go tablet is 1280x1920 (native) in portrait. This is the primary display. TV monitor is 1080x1920 (native) also in portrait.

I tried several UltraMon settings, including stretch and "same resolution", and checked the option to turn off 3d, but these did not improve the frame rate on the monitor. I tried the monitor in normal portrait, and also with both horizontal and vertical flip selected, but they both look the same.

The current TV I am testing with is a Sony TV - I tried several "scene" settings to make sure the TV was not affecting the video rate, but they all behave the same.

I also tried setting the graphics priorities in Windows for both Chrome and UltraMon to high performance. This made little or no difference.

I have yet to try optimization flags or the profiling features in Chrome, but I doubt that will yield any clues. As I mentioned in my OP, Chrome is running in kiosk full-screen mode.

wtnh   2022-05-17 06:53
Here is another clue - if I select "duplicate displays" in Windows, the video is smooth on the TV, although it is small and does not have the rotation required (which is why I am trying UltraMon mirroring in the first place).

BTW - Samsung makes a special TV monitor for display purposes that can rotate the display 90 degrees, but this is a costly alternative. Also, there appear to be some HDMI hardware boxes that can do the same, but I am hoping for a low-cost solution since this is for a non-profit museum display.

Christian Studer   2022-05-17 15:17
The resolutions are pretty close and not that high, I don't think there's anything you can do to improve performance. My guess would also be that it's due to the performance of the video card.

Christian Studer -
wtnh   2022-05-18 06:44
Thanks - I have pretty much reached the same conclusion. I think the video frame rate will be "good enough" for our purposes, at least for the time being.

A higher-performance tablet is most likely needed.

Forums -> UltraMon™ -> Mirroring a tablet in kiosk mode

Post Reply