Post Reply

Forums -> UltraMon™ -> Visual Studio 2003 incompatibility
RFreeman   2004-02-24 10:24
When running windows forms in debug mode from visual studio 2003, the following error occurs only when ultramon is running.

An unhandled exception of type 'System.NullReferenceException' occurred in

Additional information: Object reference not set to an instance of an object.

Any future patches would be appreciated.
Christian Studer   2004-02-24 22:16
Unfortunately I can't reproduce this issue, works fine on my system.

Here's what I tested: Windows XP SP1, Visual Studio .NET 2003, UltraMon 2.4.

Test project was the C# sample MonCtl from the UltraMon SDK. I ran the application under the debugger, and had set breakpoints in both Form1_Load and btnClose_Click.

I tested with Visual Studio running on the primary (Windows taskbar) and secondary (UltraMon taskbar) monitor.

Let me know if there are any specific steps necessary to reproduce the problem. You can also mail me your test project to and I'll give it a try on my system.

Christian Studer -
Scott   2005-01-24 04:24
I have the same problem - VS.NET 2003 wont load with ultramon installed. XP SP 1.

2 monitors
Current desktop: 2560x1024 (0,0 - 2560,1024)

Monitor 1 - Plug and Play Monitor (primary):
Settings: 1280x1024, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1280,1024. Workspace: 0,0 - 1280,996
Video card: NVIDIA GeForce FX 5200
Device: \\.\DISPLAY1\Monitor1

Monitor 2 - Plug and Play Monitor:
Settings: 1280x1024, 32-bit color, 60 Hz refresh rate
Coordinates: 1280,0 - 2560,1024. Workspace: 1280,0 - 2560,994
Video card: NVIDIA GeForce FX 5200
Device: \\.\DISPLAY2\Monitor0
Scott   2005-01-24 04:32
Nevermind, apparently it was an issue with one of the recent files being on a network share that was no longer reachable.
Mr Leon   2009-06-03 10:28
Microsoft Visual Studio 2003

When you minimize it by clicking *the button on the ultramon taskbar* and then try to restore it with the button it restores:

a blank window with either:
- two restore buttons (an extra one in the place of the minimize button)... if the window was maximized.

- normal minimize and maximize buttons if it was not maximized before minimizing the window at the start.

Then, to fix the issue, you click one of the restore buttons (on the window) it correctly restores the window.

Also when the window is in this "blank" state, it's button moves to the main taskbar even if it's on the secondary monitor.

Also the "Blank" window looks like a giant stretched titlebar, with the correct (but weird looking) XP-style vertical colour gradient...

If you use the window's own minimize button then it restores just fine... only if you "unpress-to-minimize" using the taskbar button does it restore incorrectly.

Using the taskbar buttons to minimize/restore works fine with the built-in Windows XP "main taskbar"

Mr Leon
in New Zealand
Christian Studer   2009-06-03 10:35
Which version of UltraMon are you using?

Christian Studer -
JeffC   2009-06-04 04:05
I have a very similar problem. Running Vista SP2 (problem occured on Vista SP1 as well). For some reason, I do not get the "move to other monitor" or "stretch across both monitors" button on VS 2003. The minimize button on the title bar sometimes acts as move to other monitor, and sometimes it acts as "Stretch...". Occasionally, it will even minimize!

The "blank" sreen is really caused by Visual Studio strecthing across both monitors.

Running UltraMon 3.0.5 (problem existed in 3.0.3 and 3.0.4) as well.
Christian Studer   2009-06-04 10:57
JeffC, do you run Visual Studio as administrator?

Christian Studer -
JeffC   2009-06-04 23:18
Yes, the account I use is an administrator, and I have UAC turned on. I have the VS.NET 2003 shortcut set to run as admin, as well. I also have Compatibilty set to XP SP2 with visual themes disabled.

Christian Studer   2009-06-05 08:48
I'll look into this for the next release, I'm aware of an issue with the buttons if compatibility mode is used, and an issue with Visual Studio 2008 when running it as administrator (not sure if that's also an issue with VS 2003).

Christian Studer -
JeffC   2009-06-16 04:04
Thanks Christian. I finally had some time to try to test it further, and it definitly seems related to having the visual themes disabled. I have disabled the window buttons in the UltraMon compatibilty tab, and that seems to help a bit.
Foz   2011-08-03 21:48
I get the same issue as Mr Leon with the very latest version (and in the beta's). I remember trying it in the beta's saw it was broke (but being a beta figured that it was still a work in progress) and now I've come back and tried the 3.1.0 release and see that it's still broke.

It's highly irritating as I may have 3-4 IDE sessions running at once.

In fact it's better to not run the Smart Taskbar and have my normal taskbar 3 rows high instead.

Foz   2011-08-03 21:48
I should have also mentioned: I'm using XP.

Christian Studer   2011-08-04 07:14
Foz, please try if disabling window buttons etc for Visual Studio 2003 fixes the issue, you can do this via UltraMon Options > Compatibility.

Christian Studer -
Foz   2011-08-07 20:22
Thanks for the response - but no, I'm afraid tweaking any the compatibility options doesn't do anything

Christian Studer   2011-08-08 07:42
Do you also get the issue only on the UltraMon taskbar, if Visual Studio is on the monitor with the main taskbar you can minimize/restore it via clicking on the taskbar button without problems?

Christian Studer -
Foz   2011-08-08 20:45
Yes - it works fine on the main task bar, but not the Smart Taskbar.

It also doesn't matter if it's maximised or not, I just get a window of titlebar.

Christian Studer   2011-08-09 09:33
I have now tested with Visual Studio 2003 SP1 and have been able to reproduce the issue, will look into this for the next release.

Christian Studer -
Foz   2011-08-09 20:16
Thanks :)

Forums -> UltraMon™ -> Visual Studio 2003 incompatibility

Post Reply