Post Reply

Forums -> UltraMon™ -> fullscreen under taskbar w/ultramon unless always on top
Eric Taylor   2004-03-10 03:55
I've noticed that with programs that can go full screen mode, I need to also specify always on top or else the taskbar remains on top when ultramon is running. If I exit ultramon, behavior is as expected. Is there some setting I've missed here?

Two examples are roxio maxdvd, and visual c++. The latter has no always on top, so I have to close UM if I want to browse full sceen in vc++.

Christian Studer   2004-03-10 06:10
Works fine for me with Visual Studio .NET 2003, I tested on Windows XP SP1 with UltraMon 2.4.

Do you have the same problem with Internet Explorer's fullscreen mode?

Christian Studer -
Eric Taylor   2004-03-11 03:23
Yes, just tried it. It's slightly different. For about 1 second, IE is on top, then the taskbar pops up to the front again.

FYI, I have the smart taskbar on my second monitor, and with IE, full screen mode works but the second taskbar (on mon 2) now works in the auto hide mode (but autohide is NOT checked), i.e. if I move the mouse to the bottom the taskbar on that monitor scrolls up (not pops up and stays like it does on the main monitor).

If I click on this second taskbar, then it stays on top even when I move the mouse up and off the taskbar.

Also, I have my primary/secondary switched.

Some settings:

2 monitors
Current desktop: 2176x864 (0,0 - 2176,864)

Monitor 1 - Default Monitor (primary):
Settings: 1152x864, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1152,864. Workspace: 0,0 - 1152,803
Video card: NVidia Riva TNT2 Model 64
Device: \\.\DISPLAY1\Monitor0

Monitor 2 - Default Monitor:
Settings: 1024x768, 32-bit color, 60 Hz refresh rate
Coordinates: 1152,0 - 2176,768. Workspace: 1152,0 - 2176,736
Video card: Viper V330
Device: \\.\DISPLAY2\Monitor0

Eric Taylor   2004-03-11 03:25
Oh, running win2k, sp4.

Christian Studer   2004-03-11 06:43
Thanks for the information, I have now been able to reproduce the problem.

On Windows 2000, the Smart Taskbar seems to prevent the Windows taskbar from hiding if a fullscreen window is active on the monitor with the Windows taskbar. Disabling the Smart Taskbar fixes the problem. This problem does not occur on Windows XP.

I'll look into this issue for the next release.

Regarding the Smart Taskbar behavior: this is by design, UltraMon will switch to autohide mode if a fullscreen window is on its monitor, and clicking on the taskbar will prevent it from hiding again until you click on another window.

Christian Studer -
Forums -> UltraMon™ -> fullscreen under taskbar w/ultramon unless always on top

Post Reply