Post Reply

Forums -> UltraMon™ -> Remote Desktop sessions appear on wrong smart taskbar
RichardBerg   2005-06-02 05:42
The Remote Desktop client correctly remembers its previous location (maximized on 2nd monitor). However, it shows up on the smart taskbar of monitor 1. A workaround is to restore/re-maximize, but that's annoying as I launch new TS sessions frequently.

Also, not sure if this is expected, but TS windows don't have ultramon's custom icons on theor window bar.

Win2k3 SP1 x64, Ultramon
Christian Studer   2005-06-03 00:32
Thanks for the bug report, the issue has been fixed.

Regarding the window buttons: the problem is that Remote Desktop uses a custom title bar when in fullscreen mode. UltraMon can only add window buttons if the window uses a regular title bar.

Christian Studer -
RichardBerg   2005-06-03 01:44
You're welcome. I figured the ultramon icons only worked on windows that use the standard title control, but I've seen them show up on some nonstandard/skinned apps (e.g. Trillian) so I wasn't sure.

Is there an updated beta?
Christian Studer   2005-06-03 08:00
Depends on how the application works, for example Yahoo Messenger has a skinned title bar, but it's actually a regular title bar with a custom look.

You can disable the UltraMon window buttons for these applications under Options > Window Title Bar.

The final 2.6 release will be ready soon, currently I have no plans for an additional beta release.

Christian Studer -
RichardBerg   2005-06-15 06:16

This bug still repros on the released v2.6 (build I'm not sure how specific your fix was, but it turns out my scenario is slightly different than I described before. Windows Display Properties looks like this:

|Mon |Mon |
| #2 | #1 |

The one on the left is marked primary, and has my start menu + regular taskbar etc. I launch RD sessions onto the secondary (right-hand, #1) monitor. This causes RD to appear on both the main (left) taskbar and the smart (right) taskbar until I restore/maximize as workaround.

Christian Studer   2005-06-15 08:14
I can't reproduce this issue with 2.6, works fine for me.

Here's what I tested:

UltraMon 2.6 on Windows XP x64. Monitor 2 on the left, primary, with Windows taskbar, monitor 1 on the right with UltraMon taskbar. Both monitors use 1024x768 resolution.

I created a shortcut for a fullscreen remote desktop session on monitor 1. I then launched this shortcut from the desktop on both monitors 1 and 2. Both times Remote Desktop launched fullscreen on monitor 1, with no task button for it on monitor 2.

Both taskbars are always on top, no auto-hide.

Let me know if there's anything else I could do to reproduce the issue.

BTW, did you uninstall the beta before installing the final release? Upgrading the beta isn't supported.

Christian Studer -
RichardBerg   2005-06-16 04:47
Uninstalling and reinstalling worked (without a reboot, even). Thanks.
Forums -> UltraMon™ -> Remote Desktop sessions appear on wrong smart taskbar

Post Reply