Post Reply

Forums -> UltraMon™ -> Eclipse and ultramon x86_64
CAL   2006-11-08 10:45

I have been trying out Ultra Mon, and have noticed that there are some problems with 64 bit version running under XP 64 Pro. The most significant problem is that Eclipse and ultra mon are not happy together. Widgets disapear, the mouse does not interact correctly with widgets etc.

I am not the only one to have noticed this:

The other problems are related to dragging window between screens. Seem like the windows don't always want to move and the "move to other display " title bar button often does not move the window. The window flashes a couple of time but stays where it is.

What are the chances of these being fixed?

Christian Studer   2006-11-09 08:33
Is there anything special I need to do to get Eclipse running on Windows x64?

I downloaded the Eclipse SDK 3.2.1, but running it on Windows x64 fails with the error message

java.lang.UnsatisfiedLinkError: M:\Temp\eclipse\configuration\org.eclipse.osgi\bundles\82\1\.cp\swt-win32-3235.dll: %1 is not a valid Win32 application

Eclipse works fine under 32-bit Windows.

Christian Studer -
CAL   2006-11-09 19:37
Hard to say, I did a quick google/bugzilla search for your error and did not find anything. (Was very quick though)

I am using the win32 eclipse 3.2.1

It requires a jre. I am currently using 1.5_09, but have been using 1.5_x earlier. I am also using the 32 bit version for this.

I would recommend installing the jre first. If you did this the wrong way round - you can delete the folder containing eclipse and just re-unzip completely and all should be well. I tested this in a virtual machine: I tried to run
eclipse before the jre was available, subsequent attempt to run eclipse after the jre was installed still failed.

Be sure to unzip eclipse bundle properly too if you open and the folder using windows built in zip handler, it seems to leave some of the files behind.

Let me know if you are still having trouble launching eclipse.

Christian Studer   2006-11-10 10:41
The problem was that I had installed the 64-bit version of Java, after installing the 32-bit version, Eclipse worked fine on Windows x64.

I've been able to reproduce the issue with the new project dialog, seems to be either an Eclipse or Windows issue. The problem occurs if certain types of hooks are installed, even if those hooks don't do anything.

There is no good workaround for this, you would need to disable the following UltraMon features so that the hooks which cause the problem no longer get installed: Smart Taskbar, moving of maximized windows with the mouse, window buttons and menu commands.

I would recommend contacting Eclipse Support as well, tell them that installing either a global WH_CALLWNDPROC or WH_CALLWNDPROCRET hook causes the problem, even if the hook procedure doesn't do anything except call the next hook via CallNextHookEx.

Another application with the same problem is REALbasic, see this thread for more on the issue.

Regarding the issue with the Move Window button: does this happen only with Eclipse, or also with other applications?

I've done some testing with Eclipse, but haven't noticed any issues with the Move Window button.

Christian Studer -
CAL   2006-11-11 04:25
I actually contacted eclipse "support" first, because I thought it was a problem with their software. Through various suggestions I managed to track down the problem to the "conflict" between eclipse and ultra mon. That is how I came to post the original message. I am glad you have managed to isolate the problem so well, I will re-open the bug with the eclipse people with information you have provided (and try to find somewhere to report it as MS).

The features you have listed are the ones I like and would use the most... pitty.

WRT to the move button. I unfortunately did not make a note of which windows where causing the problem. I will do so in the future and post back what I find.

I have just noticed that skype also suffers...
For example, when resizing the skype contact list window when ultra mon is running results in the window not being painted correctly. The problem disapears after ultra mon has been closed. I have just updated to the latest version ( and the problem persists.

Thanks for quick feedback

Christian Studer   2006-11-12 08:32
It's the exact same issue with Skype, if those types of hooks are installed, even if they don't do anything, the problem occurs.

Looks more and more like a Windows issue, I'll contact Microsoft as well.

Christian Studer -
Rob   2007-10-15 06:36
I had the same problem with ultramon and eclipse too. When I came home (were I had also the problem on my laptop without ultramon!) and started searching for other freaking software I found out that Asus Multiframe in combination with eclipse also causes these strange problems.
Christian Studer   2007-10-15 10:15
I would recommend testing again with UltraMon 3.0 Beta 2 when available, this will handle hooking differently.

Christian Studer -
Forums -> UltraMon™ -> Eclipse and ultramon x86_64

Post Reply