Post Reply

Forums -> UltraMon™ -> Move from primary to secondary monitor stops working after some time
John   2008-03-07 02:53
After I have been using UltraMon for a while (Win XP 64) the 'move to other monitor' function stops working for moving windows from the primary monitor to the secondary monitor. The only way to move a window in this direction at that point is to un-maximize it, drag to the other monitor and then re-maximize. Strangely, moving from the second monitor back to the primary monitor still works as expected.

This continues until I restart the computer. Simply closing and restarting UltraMon doesn't help. I can't be certain, but I think this only starts to happen after I have used Windows RemoteDesktop to connect to my PC over a VPN from home.
Christian Studer   2008-03-07 11:06
I'm not sure what would cause this, I also haven't been able to reproduce this issue so far, moving maximized windows via the UltraMon Move Window button worked fine after connecting to the system remotely, then logging in locally again.

Testing was done on 64-bit XP with UltraMon 3.0.2.

Christian Studer -
John   2008-03-10 03:35
OK, I was still using the non-beta 2.7 version since I didn't see any release notes that led me to believe my issue was fixed in later versions. I just upgraded to 3.0.2 so hopefully the problem will not recur.

John   2008-03-12 12:19
Sadly, upgrading to 3.0.2 did not resolve the issue.
Christian Studer   2008-03-13 10:48
Do you see any difference in the monitor configuration shown under UltraMon menu > About before/after the issue occurs?

Christian Studer -
Josh Nisly   2009-07-27 02:19
I have this happen consistently. For me, it always happens after connecting to the computer via remote desktop (using rdesktop). I don't remember if it starts happening every time I RDP in, but whenever it happens, it's after an RDP session. I'm using 3.0.2.
Christian Studer   2009-07-27 07:46
So far I haven't seen this myself, if you find out anything else let me know and I'll look into it. You could also copy the system information from UltraMon menu > About when this happens the next time, this might help with troubleshooting.

BTW, I would recommend upgrading to the latest beta release, 3.0.7.

Christian Studer -
Josh Nisly   2009-08-28 02:48
Here's my monitor info:
3 monitors
Current desktop: 3680x1920 (0,0 - 3680,1920)

Monitor 1 - Plug and Play Monitor:
Settings: 1280x1024, 32-bit color, 60 Hz refresh rate
Coordinates: 1200,768 - 2480,1792. Workspace: 1200,796 - 2480,1792
Video card: NVIDIA GeForce 8500 GT
Device: \\.\DISPLAY1\Monitor0

Monitor 2 - Plug and Play Monitor:
Settings: 1200x1600, 32-bit color, 60 Hz refresh rate
Coordinates: 2480,176 - 3680,1776. Workspace: 2480,204 - 3680,1776
Video card: NVIDIA GeForce 9400 GT
Device: \\.\DISPLAY2\Monitor2

Monitor 3 - Plug and Play Monitor (primary):
Settings: 1200x1920, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1200,1920. Workspace: 0,28 - 1200,1920
Video card: NVIDIA GeForce 9400 GT
Device: \\.\DISPLAY3\Monitor0
Christian Studer   2009-08-28 08:05
So far that looks okay, you should have monitor 3 (primary) on the left in portrait mode, monitor 1 at the center in landscape mode, and monitor 2 on the right in portrait mode. Is that correct?

Christian Studer -
Josh Nisly   2009-08-28 08:12
Yes, that is correct.
Christian Studer   2009-08-29 09:04
If you reboot the system, do you still have the exact same display configuration, and does moving of windows work again?

Christian Studer -
Josh Nisly   2009-08-31 01:18
If I reboot, the display configuration is exactly the same, but moving windows *does* work. I'd be willing to try a debugging version, if that would be helpful.
Christian Studer   2009-08-31 07:39
Unfortunately I don't know what would cause this, there's also nothing that could be tested, the only thing that could go wrong in UltraMon would be related to the display configuration, but if that's the same then it's got to be something else.

I'm assuming restarting UltraMon doesn't fix the problem, and the Move Window hotkeys also no longer work when this happens (you can configure hotkeys under UltraMon Options > Hotkeys). If that's not the case, let me know.

Christian Studer -
Josh Nisly   2009-09-01 07:09
I don't know if this helps, but when this occurs on a maximized window, it appears that the window restores (perhaps in preparation to move?), the re-maximizes. The effect is only visible for slow-painting windows such as Firefox, but it's very visible there.

Oh, and I'm also using XP x64.
Christian Studer   2009-09-01 10:17
This is due to a compatibility setting for Firefox, 'use alternative method to move maximized window' is selected for Firefox by default under UltraMon Options > Compatibility.

UltraMon usually moves maximized windows without restoring them first, but this can cause problems for some applications.

Christian Studer -
Josh Nisly   2009-09-03 01:08
Sure, it's just interesting that UltraMon is trying to do *something*. Perhaps it's not that helpful.
Christian Studer   2009-09-03 09:26
For some reason the window doesn't get moved when UltraMon tells the operating system to move the window, unfortunately I don't know why this would happen if it otherwise works fine with exactly the same display configuration.

Christian Studer -
Josh Nisly   2009-09-06 23:35
Well, considering that two people that reported this problem both have Win XP x64, a fairly fringe operating system, I'm willing to blame Windows.

For the record, my old computer was a normal XP Pro computer; I used it in the same way, and never had a problem.
Whitney   2009-09-22 07:30
I just had the problem reported on a Windows XP Pro SP2 system... just fyi (so apparently it's not just the 'fringe' OS ;).

She'd been remoted into her computer from the reception desk and then when she went back to her own desk, some of the windows wouldn't move to the secondary monitor (since it was only some of them, I'm not sure if it was the ones that were on the secondary monitor when she initially connected, so they were 'dragged' over to the primary monitor for the session, since the connecting computer was only a single monitor, and maybe that confused UltraMon... or if there's some other pattern)
Brett Kennedy   2009-10-04 01:22
I have the same issue using Vista 64 with UltraMon 3.0.7. If I reboot everything works perfectly. During that session, after reboot, Ultramon will allow me to send windows from one screen to another without any issue. If I walk away from the computer it will enter some state of power saving after 10 minutes. Upon my return I wake the computer up by moving the mouse. At this point I have a 50/50 chance that UltraMon will work correctly. Like an earlier post said, if I close UltraMon and restart it the window moving feature still will not work. If I reboot then everything if fine again.
Richard   2009-11-11 04:16
I too have had this problem with both Vista Business and Windows 7 (both 64-bit).

I find it is most likely to occur after I have used remote desktop to my PC.

In my case, instead of moving the window, it makes the window the maximum size of the monitor (*not maximized).

Also in my case, I have to restart to clear the problem.
JM   2010-05-11 06:05
I too have this problem. Using v3.0.10, I'm running XP64 with an nVidia card and dual displays.

The problem occurs after connecting via RDP (though not every time! only about 7 out of 10 instances).

Sometimes, disabling/enabling the secondary display fixes the problem. However, I am usually forced to restart.

Christian Studer   2010-05-11 08:45
JM, does restarting UltraMon also not fix the problem for you?

Christian Studer -
Ray   2010-05-17 05:40
I have been experiencing the same problem running with Win7 (x64):

2 monitors
Current desktop: 3840x1200 (0,0 - 3840,1200)

Monitor 1 - DELL2407WFPHC (primary):
Settings: 1920x1200, 32-bit color, 59 Hz refresh rate
Coordinates: 0,0 - 1920,1200. Workspace: 0,0 - 1920,1160
Video card: NVIDIA GeForce 8600 GTS
Device: \\.\DISPLAY2\Monitor0

Monitor 2 - DELL S2409W:
Settings: 1920x1080, 32-bit color, 60 Hz refresh rate
Coordinates: 1920,0 - 3840,1080. Workspace: 1920,0 - 3840,1040
Video card: NVIDIA GeForce 8600 GTS
Device: \\.\DISPLAY1\Monitor0

Restarting UltraMon didn't solve the issue. Restarting Win7 did. I occasionally RDP into this box, so I tried doing that to see if that caused the error (based upon an earlier comment). It did not.

I will try to pay attention to see if I can come up with a way to reproduce the error.
Christian Studer   2010-05-17 09:16
Ray, the display settings look okay, let me know if you find out anything else.

Christian Studer -
JM   2010-05-19 06:02
Restarting Ultramon never seems to fix it. However, disabling/enabling the secondary display does sometimes work.

Unfortunately, 9 out of 10 times I'm forced to restart.

Christian Studer   2010-05-19 07:36
Do you have a video card utility installed which might interfere with the windows getting moved by UltraMon, for example the Nvidia nView Desktop Manager or ATI HydraVision?

Christian Studer -
JM   2010-05-25 22:58
Yes, I'm using nView to enable "Dualview"

If this is a conflict, how would I disable it while still retaining the other benefits?

Christian Studer   2010-05-26 10:20
You would only need to disable the NVIDIA nView Desktop Manager (the option is under Control Panel), you'll still be able to configure video card settings via Control Panel > NVIDIA Control Panel.

Christian Studer -
JM   2010-05-31 01:32
I've disabled the nVidia services. Will report back.

JM   2010-06-03 01:54
Disabling the nVidia services had no affect. I still need to restart after connecting via RDP.

Christian Studer   2010-06-03 10:54
Unfortunately I don't know what else might cause this, if you find out anything new let me know and I'll look into it.

Christian Studer -
Josh Nisly   2010-06-07 02:06
This continues to happen for me as well, even after upgrading to Windows 7 64-bit.

Interestingly, when the keystroke to move the window doesn't work, I can use the button on the window title to move the window successfully. Does this help?
Christian Studer   2010-06-07 09:41
Very odd, both move windows the same way. Do other UltraMon hotkeys still work fine when this happens?

Christian Studer -
JM   2010-06-08 03:19
When I have the problem neither the hotkeys nor the window bar buttons for relocating the windows work. However, the window span button does work.

One other piece of info... when I'm having the problem, the screen swapping always forces the window back to the primary display, but will not swap back.

Christian Studer   2010-06-08 08:17
No idea what might cause this, the only explanation I can think of is that UltraMon would use invalid monitor coordinates when calculating the position of the window, but that doesn't seem to be the case, I already confirmed this with Josh last year.

Christian Studer -
jeff briggs   2010-06-24 06:36
if the key your using is a number, turn off num lock!
Sean   2010-06-28 06:17
Just wanted to mention that Firefox 3.6.6 "broke" ultramon's desktop changing function. I guess its because Firefox changed the way that maximized windows are handled?

Anyway, I unchecked the compatibility setting in Firefox's section in Ultramon and now it's fixed.
Christian Studer   2010-06-28 08:56
Sean, which version of Windows are you using? This works fine for me with Windows 7, Firefox 3.6.6 and the 'use alternative method to move maximized window' compatibility option enabled for Firefox.

Christian Studer -
Tom   2010-08-09 03:31
I'm having the same issue. Win XP 64 bit, all updates installed, 2 monitors, Nvidia NView Desktop manager running, UltraMon 3.0.10.

Every few days hotkey to move window to another monitor stops working (i.e. moving to secondary monitor works, but then camn't move back to primary). Button to do this still works. Restarting Windows (only) fixes things. Restarting UltraMon / disabling-enabling monitors doesn't work.

Here's my monitor info:
4 monitors, 2 disabled
Current desktop: 3200x1200 (0,0 - 3200,1200)

Monitor 1 - Plug and Play Monitor:
Settings: 1600x1200, 32-bit color, 60 Hz refresh rate
Coordinates: 1600,0 - 3200,1200. Workspace: 1600,0 - 3200,1170
Video card: NVIDIA Quadro NVS 295
Device: \\.\DISPLAY1\Monitor3

Monitor 2 - Default Monitor (disabled):
Settings: 1280x1024, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1280,1024
Video card: NVIDIA Quadro NVS 295
Device: \\.\DISPLAY2\Monitor3

Monitor 3 - Plug and Play Monitor (primary):
Settings: 1600x1200, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1600,1200. Workspace: 0,0 - 1600,1170
Video card: NVIDIA Quadro NVS 295
Device: \\.\DISPLAY3\Monitor2

Monitor 4 - Default Monitor (disabled):
Settings: 1280x1024, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1280,1024
Video card: NVIDIA Quadro NVS 295
Device: \\.\DISPLAY4\Monitor2

Fred Kuipers   2010-09-08 05:35
I too have this issue -- and have had this issue since the 2.x days. I'm currently running 3.0.10 on two PCs:

Work PC:
- Monitors: Originally 2 but now 3 1680x1050 (landscape) monitors on NVidia Quadro video card(s).
- Windows Vista Business x64 SP2 with updates

Home PC:
- Monitors: 2 2048x1152 monitors on an NVidia GeForce GTX 460.
- Windows 7 Pro x64 with updates

I can reliably reproduce this issue two ways:
1: Remote desktop (work PC)
2: Disconnect monitors until only a single monitor remains (home pc).

- Cannot use the move to other monitor button to relocate a maximized window to a non-primary monitor. (In the 3-monitor case, if the window is currently on monitor two and I wish to move it to monitor 3 using the button, it ends up on monitor 1 - primary).
- Keyboard shortcuts mapped to the Move to next/previous monitor commands don't move the window -- the window is "stuck" on the current screen.

- Windows Vista/7 seem to allow dragging of maximized windows, so I can do this.
- Logout and back in usually fixes it. If it doesn't, reboot.

The trigger really seems to be when Ultramon drops to single monitor mode and then back into multi-monitor mode.

This is the most frustrating issue with ultramon that affects me as I remote desktop from home to work often and use my home monitors at home for other things often as well.

Thanks for an otherwise excellent utility.

Christian Studer   2010-09-08 09:56
Should be fixed in the next release, I looked into this with a customer and think we found the problem, just need to confirm the fix is working.

Christian Studer -
Fred Kuipers   2010-09-08 11:02
You have no idea how happy I am to hear this. Thanks!

If you'd like another tester-type, I'll be happy to volunteer.

JM   2010-09-30 01:14
While we're awaiting the next release, I have found a workaround which doesn't require a reboot(works in Win7 64bit)

1. Disable the secondary through the taskbar icon
2. Close Ultramon
3. Restart Ultramon
4. Enable Secondary through the taskbar icon

The screen swapping now works.
Chris   2015-02-04 01:52
I've just started having this same issue, since getting a new 27" monitor.

I'm using Win8, Ultramon details below:

2 monitors
Current desktop: 1920x2160 (0,0 - 1920,2160)

Monitor 1 - Generic PnP Monitor:
Settings: 1920x1080, 32-bit color, 60 Hz refresh rate
Coordinates: 0,1080 - 1920,2160. Workspace: 0,0 - 1925,1049
Video card: Intel(R) HD Graphics Family
Device: \\.\DISPLAY1\Monitor0

Monitor 2 - PHL 273V5 (primary):
Settings: 1920x1080, 32-bit color, 60 Hz refresh rate
Coordinates: 0,0 - 1920,1080. Workspace: 0,0 - 1925,1049
Video card: Intel(R) HD Graphics Family
Device: \\.\DISPLAY2\Monitor0

Any help gratefully received.
Christian Studer   2015-02-04 13:58
Chris, what exactly happens when you click on the Move Window button? Also let me know which version of UltraMon you're using.

Christian Studer -
Forums -> UltraMon™ -> Move from primary to secondary monitor stops working after some time

Post Reply