Post Reply

Forums -> UltraMon™ -> UltraMon 3.0.4 Beta released
Christian Studer   2009-01-11 11:32
UltraMon 3.0.4 Beta has been released, this release has new Smart Taskbar features and several bug fixes. See the release notes for details, download here.

Christian Studer -
Brad   2009-01-11 14:06
I just got the email and tried to install the new beta and I received a error that "This installation package is not supported by this processor type. Contact your product vendor."

I am using Vista Enterprise with SP1 with Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz 2.39GHz

Will I now not be supported by UltraMon to use in the future?
Michael   2009-01-11 16:17
Sounds like you may have downloaded the incorrect version?

Are you running 32-bit or 64-bit Windows? which version did you download?
Mustang   2009-01-11 16:56
Thanks team UltraMon
Been looking forward to this for a while
Mustang   2009-01-11 17:02
Oops already got my 1st error

Version: 3.0.4
OS: 6.0.6001 Service Pack 1 x32
Source file: .\MultimonGUI.cpp
Line: 3183
Return value: 0
Last error: 0
Ola Ström   2009-01-11 21:18
Thank you Christian for adding support for multiple rows on the second Taskbar.

You just made my day :)

That was the only thing I was missing in UltraMon before, now it's just perfect.

I can live with that the animation is not there as on the main Taskbar (from hidden to visible).

sleo   2009-01-11 23:32
With 3.0.4 (32 bit, on Vista Home Premium) file search application Avafind stopped working.

When Ultramon is running, app has a grayed top menu and doesn't respond to left click or keystrokes (responds to right click though).

When I quit Ultramon, everything gets back to normal, when I start it again, again the same behavior. All the other apps work just fine with new Ultramon.

I removed all the hotkeys from Ultramon as i thought they may be interfering with Avafind, but no change.

Any other tips?

Bob   2009-01-12 02:37
After installing 3.0.4 (using x64 version with Vista), right-clicking on the system tray icon no longer brings up a menu. Reinstalling 3.0.3 returns things to normal.
jhuk   2009-01-12 03:19
Still the same bug as every build.

I have waited patiently on fixes and claims you cannot these even though many others have same issues.

I paid for the full version hoping eventually after over 2 years of Vista it would work.

Now the talk is Windows 7 Beta, well I think you need to get it to work in Vista 1st since Windows 7 is basically Vista SE.

I cannot use this Software in current state, I continue to Enable/Disable 2nd Monitor through Nvidia CP or the Ultramon Extension on the Nvidia CP since I cannot use the simply Enable/Disable Menu without issues.

Screen shot inc, not as bad as other times but still a mess.


The black square at bottom of Sidebar is not the Sidebar, its remains a hole in the screen after I close the Sidebar.

I bought this for Vista after trial use as I had no choice and have never had it working fully for basic function of working with a Monitor+TV.
jhuk   2009-01-12 03:19
entersecurity   2009-01-12 05:34
Getting an error the second time I try to enable/disable the secondary monitor after starting UltraMon

Version: 3.0.4
OS: 5.1.2600 Service Pack 3 x32
Source file: .\MultimonGUI.cpp
Line: 3183
Return value: 0
Last error: 0
dodudo7   2009-01-12 07:09
I get same error here, too.
Version: 3.0.4
OS: 5.1.2600 Service Pack 2 x32
Source file: .\MultimonGUI.cpp
Line: 3183
Return value: 0
Last error: 0

Very easy to reproduce it.
It happens when I right click the second time on the tray icon. There is no need to select anything from the menu after fist time, just click anywhere else on the desktop and then right click for the second time on the ultramon tray icon and... bang!

Moved back to 3.0.3!
Michael   2009-01-12 07:34
No crashes here, running Windows XP Professional Service Pack 3. The only 'problem' I have is that when I right click the Smart Taskbar on my second monitor, the menu pops up a bit late, I have to wait like a second before it pops up.
Michael   2009-01-12 07:35
32 bit by the way
mbarnes   2009-01-12 08:22
Who the #$%!^ cares about new features when
basic functionality is still seriously

Ultramon has been crashing on me randomly,
several times a day, since the first 3.x
beta I downloaded many, many months ago.

Please debug and fix it before even
thinking about adding new features.

Christian Studer   2009-01-12 11:45
Fatal error in MultimonGUI.cpp at line 3183: can't reproduce this by disabling secondary or clicking on the tray icon, if someone would be interested in running a test version to look into this further let me know.

sleo, I've been able to reproduce the issue with AvaFind, will look into this for the next release. As a workaround, disable window buttons for the application via UltraMon Options > Compatibility.

Bob, can't reproduce this issue, do you get an error message?

jhuk, I can't tell you anything new, I would need to be able to reproduce this issue in order to look into it. So far I had no issues with the Sidebar when disabling/re-enabling the secondary, one thing you could check is if the problem only occurs with a specific gadget, I only have the default gadgets enabled (clock, headlines, slideshow).

Christian Studer -
jhuk   2009-01-12 13:38
I will load all MS default gadgets but again It is damaging behind/under the Sidebar also.

It at times as you know used to mess up complete Desktop inc Icons and make ghost services appear.

I will do this tomorrow (GMT).
sleo   2009-01-12 19:37
I found solution to my problem (2009-01-12 05:32) - turning off both window title buttons

They worked ok with 3.0.3.
jhuk   2009-01-12 23:56
Hmm, I have loaded Windows Default Sidebar items but same as last night, this new build keeps closing itself when I put my mouse over its Notification Area Icon.

This never happened on previous builds and I got an actual error the other night also (will note it next time).
Drarok   2009-01-13 00:38
The GUI build of vim (gvim.exe, v7.1.303) crashes with the new beta when a window is maximised.

Workaround: Disable window buttons, no more crashes. :)
Ryan   2009-01-13 03:06
The new release looks great, seems to have solved a few of the very annoying bugs that I was encountering regarding windows always being on top. Great work. I can't believe all the users who are so rude on this board...

I am also able to reproduce the line 3183 bug mentioned above, using Vista. I am willing to run a test version and help debug if you want, I am also a software developer. Feel free to email me if interested.
Christian Studer   2009-01-13 04:10
Drarok, I'll look into the vim issue for the next release, but there's most likely no fix for this.

Ryan, thanks for the offer, I'll contact you by e-mail once I have something available for testing.

Christian Studer -
Mustang   2009-01-14 01:02
Got another one for you:

Version: 3.0.4
OS: 6.0.6001 Service Pack 1 x32
Source file: .\TaskBand.cpp
Line: 716
Return value: 0
Last error: 0
Christian Studer   2009-01-14 02:32
Thanks for the bug report, will look into this for the next release.

Christian Studer -
Sohan   2009-01-14 05:15
Hope the next release is real soon. I still can't get this working on windows 7!
Christian Studer   2009-01-15 05:00
Support for Windows 7 is planned, but most likely won't be added before 3.0 final.

Disabling the window buttons in the registry will allow you to use UltraMon, to do this run regedit.exe, go to 'HKEY_CURRENT_USER\Software\Realtime Soft\UltraMon\<version>\Window Buttons', then change the value of 'Maximize to Desktop Button' and 'Move Window Button' from one to zero.

Christian Studer -
Ray   2009-01-17 05:44
The gvim crash is because vim uses WM_APP+0 for some messages (i.e. MSG.message = WM_APP+0) when OLE support is enabled. Ultramon is apparently sending messages using this same value. However, vim expects a valid pointer in the MSG.lParam, which it tries to free: boom.

I compiled a version of vim using WM_APP+1 for its OLE messages and the crash disappears.

I am not a contributor to the vim project, and therefore not familiar with the codebase, so I don't know if this is a good fix or not.

I'm not intending to imply that Ultramon is in the wrong, but would it make sense to use a more unique number for its WM_APP messages?

As far as vim goes, I think that it should check for a valid address before it tries to free it, and I'm going to try to submit that patch.

Thanks for the great product!
Christian Studer   2009-01-17 07:35
Might be an option, but I would only want to do this if this is a common compatibility issue.

Most apps should have no problem with this because the message loop simply forwards messages to the appropriate window procedure, which does the processing. If gvim would do this, it would never see the WM_APP messages from UltraMon.

Christian Studer -
Stefan D. Poulsen   2009-01-18 17:26
Currently really annoyed by the fact that the primary taskbar shows up on my secondary monitor, and I have no way of getting it on the primary monitor.

Setup is a HP 8710w with a HP L2208w monitor connected.
Christian Studer   2009-01-19 08:43
You can just drag the taskbar to the other monitor, just make sure it isn't locked.

Christian Studer -
mbarnes   2009-02-17 03:40
UltraMon *still* crashes time after time after time, all day long.

Give me a debug version and I'll be happy to run it for you.

mbarnes   2009-02-18 03:06
So it's actually Ultramon's Smart Taskbar that's the problem...

Jim Millard   2009-03-05 06:09
Just switched from 3.0.2 to 3.0.4, and I'm able to repro the right-click tray-icon error.

It only causes ultramon.exe to die; the smarttaskbar stays active and functional.

I'm on XPSP3, with an nVidia Quadro VNS285 running older drivers. I'll update to latest/greatest and see how it flies...
Steve   2009-04-19 15:29
UltraMon encountered a fatal error and will exit.

More information:

Version: 3.0.4
OS: 5.1.2600 Service Pack 3 x32
Source file: .\MultimonGUI.cpp
Line: 3183
Return value: 0
Last error: 0


Occurs the second time I right-click the UltraMon icon. The second taskbar appears to still be functional. This did not occur on the stable 2.x version that I have installed prior to upgrading to the beta.

Will appreciate any work-arounds to this.
Christian Studer   2009-04-20 12:43
Will be fixed in the next release, as a workaround disable the window management menu option under UltraMon Options > Customization.

Christian Studer -
Danny   2009-04-22 04:30
I'm running UltraMon 3.04 Beta on Windows 7 (build 7000), which I know isn't officially supported, but I just thought I'd point out that hotkeys lose their actions at random. They'll work for a while and then stop working randomly until I restart UltraMon.

Keep up the good work!

Russell G   2009-05-03 07:00
Just a repeat of the bug report above from Mustang on 2009-01-14 at 07:02.

UltraMon Taskbar encountered a fatal error and will exit.

More information:

Version: 3.0.4
OS: 5.1.2600 Service Pack 3 x32
Source file: .\TaskBand.cpp
Line: 716
Return value: 0
Last error: 0

Just before it crashed, I noticed a problem with two taskbar items on the second monitor. One was Explorer.exe and the other was Firefox. When I clicked either button, Explorer restored itself, so I was unable to get back to the Firefox window. (in other words, clicking the Firefox button restored Explorer also) I then right-clicked the Explorer button and selected Close, to exit the application. Just after it exited, I got the message above from Ultramon.
Russell G   2009-05-03 07:05
BTW, I had Taskbar Shuffle running as well. It didn't report any errors, but after I restarted UltraMon, I was no longer able to "shuffle" the taskbar buttons (this program lets you drag the buttons around on the taskbar to reorganize them). I right-clicked the tray icon for Taskbar Shuffle and disabled it, and then re-enabled it, and it started working again. Don't know if it's related to the UltraMon crash or not, but maybe it's another clue.
Forums -> UltraMon™ -> UltraMon 3.0.4 Beta released

Post Reply