Post Reply

Forums -> UltraMon™ -> New IM chat windows not appearing on Ultramon taskbar
Mark   2006-03-24 03:46
I am running three monitors with the Ultramon taskbar. My machine is an Athlon 3200+ w/ 2gb RAM.

I have Smart Taskbar enabled in Standard mode and have set the process priority to Normal (highest setting).

The issue that is occuring is that new chat windows (MSN, Spark, etc.) are not appearing on the taskbar. I have to either Refresh the taskbar (right click, Refresh) or Alt-Tab through my open apps to browse to the new window.

Has anyone else experienced this? Any solutions?

Christian Studer   2006-03-24 08:12
Unfortunately I can't reproduce this issue, I tested with UltraMon 2.6 and MSN Messenger 7.5 on Windows XP SP 2.

Here's how I tested: I had the contact list running on the primary monitor, and double-clicked a contact to open a new chat window. A button for the chat window was added to the taskbar.

Christian Studer -
Mark   2006-03-24 08:17
The issue occurs when I receive a message that starts a chat. I hear the sound, but it opens behind other programs and doesn't appear on the taskbar... the main IM window with contact list is not on the primary monitor...
Mark   2006-03-24 12:08
OK I did some more testing.

I use multiple Windows users on this machine. Only one user "User 1" has IM apps that are used.

Here are my findings when I had someone send me an IM that began an conversation:

Scenario 1:
Smart Taskbar enabled
Logged in as User 1
IM taskbar item appeared

Scenario 2:
Smart Taskbar enabled
Logged in as User 2
IM taskbar does not appear

Scenario 3:
Smart Taskbar disabled
Logged in as User 2
IM taskbar does appear

So, the problem is occuring when I am logged in as another user (by using the 'switch user' feature') and Smart Taskbar is enabled.
Christian Studer   2006-03-25 08:26
Thanks for the information, I've been able to reproduce the issue. I'll look into this for the next release, will be fixed if possible.

Please note that this problem only occurs in the following scenario:

you are logged in as user 1 and have MSN Messenger running. You then login as user 2 via fast user switching. While the user 2 session is active, user 1 gets an instant message. When switching back to the user 1 session, you won't have a taskbar button for the new message, and you also won't get any taskbar buttons for future messages until MSN Messenger gets restarted.

If no instant message is received while the user 2 session is active, the problem doesn't occur.

Christian Studer -
J   2007-11-25 07:13
Is this bug fixed? I am running version 2.7.1 and this happens very often. Is this fixed in newer version?
Christian Studer   2007-11-26 08:16
This issue was fixed in 2.7.0.

Does this happen when you're logged into a different session via fast user switching and receive a message in another session?

Christian Studer -
J   2007-12-01 12:13
This happens after the screensaver starts and I receive a message when the "log in" menu is being displayed.
Christian Studer   2007-12-02 09:12
I'll look into this for one of the next releases, probably won't make it into 3.0 Beta 2 though.

Christian Studer -
Forums -> UltraMon™ -> New IM chat windows not appearing on Ultramon taskbar

Post Reply