Post Reply

Forums -> UltraMon™ -> Smart Taskbar and Remote Desktop
Jack   2008-01-07 03:56

Great work on Ultramon,

I'm using Beta 2 and I find that the smart taskbar likes to get in front of a full screen RDP session. The windows vista one hides itself and lets the RDP session become full screen.

A quick fix is to restart RDP, but this is not optimal

Bryan Aldrich   2008-01-07 09:02
You can also click on the item, and then click on it again to max-imize it.

It happens as well with Zoom Player, and likely other full-screen applications.

Christian Studer   2008-01-07 10:28
So far I've only seen this if the fullscreen application opens and closes a dialog/popup window. UltraMon shows the taskbar when the dialog opens, but doesn't hide it again when the dialog gets closed.

Is that the same issue you're experiencing?

Christian Studer -
Bryan Aldrich   2008-01-07 11:02
Possibly Here is how i can repro it every time.

1) Open full-screen application on secondary monitor.
2) Switch to primary monitor.
3) Move application over to secondary monitor (on-top of fullscreen app).
4) Click Full-screen app item in task-bar.

At this point, the task bar will stay on-top of the full screen application.

If you drag the window back to the primary, it hides itself again.

Christian Studer   2008-01-07 11:08
Bryan, I'm seeing that as well, should be fixed in the next release.

Christian Studer -
Bryan Aldrich   2008-01-15 10:10
This is mostly working.

Alt+TAB still has the old behavior.

Grabbing the title bar and moving it a hair will fix the issue.

Christian Studer   2008-01-15 12:07
I'll look into this for the next release. For me it works occasionally, but most of the time ALT+TABing to the fullscreen app leaves the taskbar visible.

Christian Studer -
Joseph   2008-01-15 16:42

The Smart Taskbar also doesn't plays well with the fullscreen-mode window of MS Virtual PC.

Initially, it will always be on top. Using alt-tab from the primary monitor will cause the MS Virtual PC window to kind of come to the front, but the Smart Taskbar is actually still capturing any mouse event in its area.

Christian Studer   2008-01-16 09:46
Does this only happen when you ALT+TAB to a fullscreen Virtual PC window?

So far I've had no problems with Virtual PC in fullscreen mode, the UltraMon taskbar was hidden correctly and mouse input went to Virtual PC.

Christian Studer -
Joseph   2008-01-16 15:08
The mouse is always captured by the Smart Taskbar when the cursor is in its area, not only after an alt-tab. The only difference between before and after alt-tab is that the fullscreen window display is (kinda) in front after the alt-tab, while it was behind the Smart Taskbar initially.

I am using XP with the primary display on the right instead of left (negative coordinates on the secondary?) if that makes any difference.

I will be switching back to 2.7.1 for now, since it seems the only workaround to have my fullscreen Virtual PC window working properly is to make "Always on Top" unselected on the Smart Taskbar (cannot be set differently from the XP Taskbar in 3.0.2).

Thank you for responding to my post, keep up the good work :)
Christian Studer   2008-01-17 10:06
Which version of Virtual PC are you using? I tested with the 2007 version.

Christian Studer -
Joseph   2008-01-23 03:10
I am using Virtual PC 2007 as well. In the About box it says "Microsoft Virtual PC".
evan   2011-01-24 04:34
Using win7 64 pro UM smart taskbar will not stay on top no matter what.
even if i have windows taskbar stay on top setting withouth autohide, um st will hide under a maximized application.
switching monitors method wont help.
Christian Studer   2011-01-24 08:55
Evan, make sure the UltraMon taskbar is set to be always on top, you can adjust this setting via right-click on the taskbar.

If that doesn't fix the problem: does restarting UltraMon fix the problem?

Christian Studer -
Forums -> UltraMon™ -> Smart Taskbar and Remote Desktop

Post Reply