Post Reply

Forums -> UltraMon™ -> Ultramon crashes
Matt S.   2008-10-01 05:15
I stopped getting this problem in the last release before 3.0.3. Maybe different error message but its the same cause.

A second instance of my browser shows up after the browser had been minimized for awhile, on the smart taskbar almost as if it was mirroring it as minimized. When you click on that instance Ultramon crashes.

This is the error I get:
Version: 3.0.3
OS: 6.0.6001 Service Pack 1 x32
Source file: .\TaskBand.cpp
Line 725
Return value: 0
Last error: 1400

Then I have to go close the two processes that are left on in order to restart ultramon.
Christian Studer   2008-10-01 08:40
You'll get this error if the task button refers to a window which no longer exists.

Did the minimized browser hang, or did you notice anything else special?

Christian Studer -
Matt S.   2008-10-01 10:54
Nope the browser was open and responsive, it was just minimized.

And if it wasn't clear in my first post. Mirroring is turned off. So it shouldn't have had the browser on both bars.
Christian Studer   2008-10-02 08:36
I have uploaded a test version of UltraMonTaskbar.exe:

This is for 32-bit Windows only. To install it, first close UltraMon, then create a backup of UltraMonTaskbar.exe in C:\Program Files\UltraMon, extract the ZIP file to that folder and replace the original UltraMonTaskbar.exe.

Instead of displaying an error message, the test version just removes the task button. Let me know how this works out for you, unfortunately I can't reproduce this issue myself.

Christian Studer -
Matt S.   2008-10-03 05:42
Ok, I'll test it out. And see if it happens again.

Forums -> UltraMon™ -> Ultramon crashes

Post Reply